Problem with drawing curves


#1

Hello! I am new on Seamly2D, have started using the software few days ago. Thank you very much for creating it! At first I was using Valentina, then I found there was Sealy2D now. I have problems when drawing curve paths in Seamly, because the program seam to freeze for a few seconds and I can not adjust the curve in the real time, I can just move the handles and then wait for the result. It’s annoying and it takes ages to draw a desired shape. What can be the reason? I don’t experience any problems drawing straight lines and other paths, everything works quickly. Just the curve tool…It was working smoothly in the Valentina, but for some strange reason it doesn’t work in this Seamly2D version. Did anyone have the same problem and what was the solution?


Seamly 2D crashing on Mac OS Sierra
#2

Hi @huraganka, I haven’t come across this problem. Perhaps because I always just put the curve in ‘any-how’ and then open the options of the curve and put in more formula based lengths and angles.

If you could past a picture of the version of Seamly2D that you’re using and what platform you are working on (I’m on Windows 10), perhaps someone will be able to help you.


#3

Hi @Grace, thanks for answering! That’s the version of Seamly2D I’m using: 17 and I’m on MacBook with OS X Yosemite. I’m drawing curves manually mostly because I want to try different shape options, the way I am drawing for instance on Adobe Illustrator. I am still not very familiar with Seamly2D and I am constantly trying new things and options, maybe I will need to learn to work more on formulas than direct drawing.


#4

Thank you. I’m on an older version and Windows, so I’m hoping one of the programmers will see this and perhaps be able to see if this is a program issue or what.

In the meantime, here’s a little toy that I’ve tried to make that also uses the handles to change the curves. Perhaps you can check on it whether they move smoothly for you: Bird Soft Toy pattern.val (17.5 KB)


#5

Hey :slight_smile:

I’ve had the software 2 days, and overall love it. I have been experiencing the same issue with curves however, so thought I’d chime in so dev’s know it’s more than one of us.

I am also running a 2014 MacBook Pro with High Sierra 10.13.6 My version of Seamly2D is 0.6.0.1, build revision 12b271be4cdf.

I have the same problem with curves stalling or even crashing the software. Sometimes it’s ok, sometimes as soon as you select a curve everything stops for a few minutes, until ultimately the software crashes and closes. When it does work, grabbing the curve or a handle gets the macs fans on really quickly. I found that if I could make an adjustment to the curve with the formula box first, then move to grabbing the curve or handle, it seemed to be a lot happier and run smoother.

I’ve been good about saving, so hasn’t cost too much of any pattern.

Cheers,

Lee


#6

Hi and welcome, @LeRich. It seems this is a Mac problem. I have Windows so I can’t test this.

Can you please post some screenshots of the error and what you are doing when the error occurs? Also, the .val and .vit files will be helpful for the person testing and checking the problem to recreate it.

Thank you


#7

Hi @Grace, Thank you for your reply :slight_smile:

20:10pm Here is a screenshot just after I selected the curve A4-A16-A12-A11.

20:10pm The curve went red, showing it had been selected.

<a class=“attachment” href=">

20:11 From then, there was no response from Seamly2D for around 20 seconds. At this point the cursor changed to the ‘StarTrek’ arrow symbol, with a small red line at an angle below it - I believe this is the point control tool. I tried to select a handle, but there was no response from the program, so I released the mouse click.

20:18 From this point there were 7 minutes where nothing happened, until the next screen shot when the curve jumped and changed in shape. From the moment I selected the curve, the cooling fans came on, and remained on for the durations above until the curve moved. The fans then slowed back to normal again.

20:20 An addendum - when moving screens around to get the screen shot, this message just popped up from Seamly2D:

‘QGestureManager::deliverEvent: could not find the target for gesture’

I hope this helps - sorry for the multiple edits, I’m still figuring how to use the drag and drop placement of files and pictures!

If anything else is needed, please just say - I’ll send whatever I can to help :slight_smile:

SC_BodiceSlope_Pattern.val (8.3 KB)

TestMeasurements.vit (1.1 KB)


#8

Thank you for all the info and screenshots. I’ve manages to drag the handles around with no problem, delays or anything. But then, I’m on Windows 10. image

I’ve also remade the curve (in blue) with no problems: image

I’m going to create an issue so that one of the programming people can have a look and see if they can find a solution.

Issue created.


#9

Hi @LeRich,

Typically, MacBooks are considered a bit underpowered for graphics software, but we’d like to improve our software performance to minimize these issues.

Thanks for doing such a beautiful job illustrating the problem.