Help cannot change language / ayuda no se puede cambiar idioma

in the new version of the program’s installer It no longer allows you to choose the language, so there are no longer any languages ​​installed, it only leaves English by default.

Someone pass me the old version please.

I need to change it to Spanish

ayuda por favor.

2 Likes

Hello and welcome to the Seamly2D forum, @jjjjose

Here is the link where you should find the previous version: GitHub - FashionFreedom/Seamly2D: Open source patternmaking software.. Just scroll about half way down and select the Stable Version for your operating system.

1 Like

Hi @jjjjose. Reprodudé este problema. En “Archivo/Preferencias/Configurar/Idioma de etiqueta” solo estaba disponible en la lista desplegable “Inglés americano”.Cuando lo intenté de nuevo, aparecieron varios idiomas. ¿Podrías intentarlo de nuevo?

I replicated this problem. In “File/Preferences/Configure/Label Language” only “American English” was available in the dropdown list. When I tried it again, multiple languages appeared. Would you try it again?

3 Likes

Agregué un problema al repositorio aquí:

I added an issue to the repo here:

3 Likes

Thank you very much for answering. Tell them that it already solves the problem. I followed the following

First I will describe the errors I had with the new version.

  • 1.- mainly it does not let you choose the language to install.
  • 2.- It has no default accessories such as sizes or measurement examples, etc.
  • 3.- It also does not give us the option of removing the icons by Default to the desktop. (you have to remove them manually).

SOLUTION.!

  • We must return to the stable version of the program you can download it from here. Package Seamly2D-win_release - fashionfreedom
  • Remember to uninstall the new version, (WHY IT WILL NOT LET YOU EXECUTE IF YOU INSTALL IT ON TOP OF THE OLD) and ready bug fixed

NOTE: If by mistake you installed the old version on top of the new one, just reinstall the new version of the program, with it you will have the add-ons and also the chosen language.

Postscript.

  • Excuse my English, I did it with Google Translate.
  • I leave the translation to Spanish for those who are with the same error and can solve it


Muchas gracias por responder. Comentarles que ya solucione el problema. Segui lo siguiente

Primero describire los errores que tube con la nueva version.

  • 1.- principalmente no te deja elegir el idioma para instalarse.
  • 2.- No tiene complementos por default como las tallas o ejemplos de medida, etc.
  • 3.- Tampoco nos da la opcion de sacar los icono por Default al escritorio. (hay que sacarlos manualmente).

SOLUCION.!

  • Hay que volver a la version estable del programa lo puedes descargar de aqui Package Seamly2D-win_release - fashionfreedom
  • Recuerda desinstalar la version nueva, (POR QUE NO TE DEJARA EJECUTAR SI LO INSTALAS ENCIMA DE LA ANTIGUA) y listo error solucionado

NOTA: Si por error instalaste la version vieja encima de la nueva, solo vuelve a instalar la version nueva del programa, con ello tendras los complementos y ademas de el idioma elegido.

error idioma seamly2d SOLUCIONADO

1 Like

Ok it’s fixed – Download the New Release with Translations & Images FIXED!

2 Likes

similar problem with the build. archlinux seamly2d-git v0.6.0.1.r355.g9af57415f-1

1 Like

The gui language (combobox) is dynamic and depends on what translation files are present. It only stands to reason - if the translations for a particular language are not present, you can’t (re)translate the gui.

If this is the case, I don’t know why any translation files would be missing in the linux ver? Can any other linux users confirm what gui translation files are available in the latest build?

2 Likes

languages ​​if available if I use AppImage release 20201228 I am not an expert in this, but I leave here the pkgbuild that I create for the compilation

pkgname=seamly2d-git
_pkgname=Seamly2D
pkgver=v0.6.0.1.r355.g9af57415f
pkgrel=1
pkgdesc="Open source patternmaking software"
arch=('i686' 'x86_64')
url="https://seamly.net"
license=('GPL3')
depends=('qt5-svg' 'qt5-xmlpatterns' 'desktop-file-utils')
makedepends=('git' 'qt5-tools')
source=("git+https://github.com/FashionFreedom/Seamly2D.git#branch=develop")
md5sums=('SKIP')

pkgver() {
  cd "${srcdir}/${_pkgname}"
  git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}

build() {
  cd "${srcdir}/${_pkgname}"
  [ ! -e build ] && mkdir build
  cd build
  export QT_SELECT=5
  qmake PREFIX=/usr/ PREFIX_LIB=/usr/lib/ ../Seamly2D.pro -r \
  CONFIG+=noDebugSymbols CONFIG+=no_ccache CONFIG+=noTests CONFIG+=noRunPath
  make
}

package() {
  cd "$srcdir/$_pkgname/build"
  INSTALL_ROOT="$pkgdir/" make install
}
2 Likes

I’m still seeing the full list. Though since this isn’t a fresh install the old translations could still be floating around wherever they hang out. I’m not sure how to tell if they aren’t getting installed somehow, but the translation files appear to be in the recent .tar.gz source as well.

1 Like

the PKGBUILD, compile the project from the git repo according to the last commit. checking the pkg.tar.zst if you have the translations.

imagen

1 Like

That’s a very good point.

1 Like