Discourse Forum Software admin notes

administration

#1

On Digital Ocean we have a ValentinaForum account. There’s a ValentinaForum server which runs Ubuntu 16.04.

The forum runs using nginx, Discourse, and Docker software. The nginx, docker, and discourse software was installed via an install bundle downloaded from Discourse. On Ubuntu, nginx is the webserver (not Apache2 which is the default for Ubuntu). [If you ever see a bind error after trying to launch the Discourse app, the IP address 0.0.0.0 is already in use, then Apache2 is running. sudo service stop apache2, or something like that command will stop Apache2]

In /etc/nginx is the nginx software In /var/discourse is the forum software In /var/discourse/share are the forum posts, images, etc.

The forum should automatically boot upon our virtual ValentinaTeam Ubuntu server’s bootup. If the forum needs to be restarted: in /var/discourse ./launcher stop app ./launcher rebuild app [If you ever see a bind error after trying to launch the Discourse app, the IP address 0.0.0.0 is already in use, then Apache2 is running. sudo service stop apache2, or something like that command will stop Apache2]

When Discourse releases updates, the updates will be available in the admin area. Every few months, the software should be manually updated and re-started, via these instructions (note: Ubuntu’s docker package has been changed from docker-engine to docker-ce) : https://meta.discourse.org/t/how-do-i-manually-update-discourse-and-docker-image-to-latest/23325


Test downloads .val .vit .txt .pdf
#2

Today we had a lot of 500 errors, 429 errors, etc. which indicated that the server was getting too many requests. Some threads on the interwebs indicated that a DigitalOcean reboot was required.

So I logged into our Seamly2D_Forum team account at DigitalOcean, and rebooted the server.

BUT…the DO Ubuntu installation had installed Apache2 by default. When Apache2 is running it receives the requests for webpages, and the Docker/NGINX/Discourse forum cannot start. So the forum didn’t restart :frowning:

So … today I used rcconf to disable Apache2 from restarting automatically upon reboot.

Next time the forum should start automatically because apache2 didn’t take over the webservice.


New thread test