20200619 Linux Appimage Test Build!

Download the Seamly2D LINUX APPIMAGE :stars: HERE :stars:.
It runs on multiple Linux distros!
Mark the file as Executable in your file manager.

1 Like

Note: To do this in the Terminal/command line, entering chmod +x Seamly2D.AppImage should mark it as Executable by anyone with access to that computer. Assuming that you are viewing the directory which Seamly2D.AppImage is in, of course.

1 Like

Using my **Chromebook**, after a minute or so of running, I got this error while placing a point:

QXcbConnection: XCB error: 3 (BadWindow), sequence: 7061, resource id: 2097220, major code: 40 (TranslateCoords), minor code: 0

However, it did not crash, the point successfully placed, & It kept running! As I did more point placements, (experimenting with making a grid to see how that works with copying patterns pictured on a grid, so lots of simple point placements.) I continued to get variants of the same error as I went along, the variation of which can be seen below:

QXcbConnection: XCB error: 3 (BadWindow), sequence: 15682, resource id: 2097226, major code: 40 (TranslateCoords), minor code: 0

I realize that it is a somewhat non-standard implementation of Linux, & so far it has been more stable than any of my previous installs. So I’m basically mentioning this for the purpose of complete documentation. (Though I’d be happy to help figure it out if someone wants to direct me.)

1 Like

Yeah Chromebook is a platform that nobody knows how to support! Wish we could offer more help but the number of chromebooks out there is so small that the companies who create the build tools don’t even consider it in their testing platform. So when we build Seamly with those build tools there’s just no way we can support Chromebook. :cry:

2 Likes

I “installed” the Seamly2D.appimage and marked it executable (on ubuntu 20.04 installation) and it opens and appears to work. I have not tried an extensive test, just seen that I am able to open various menu actions.

It apparently does not come packaged with the icon and therefore it may not be immediately obvious to everyone how to invoke the program. It seems that SeamlyMe is included in the appimage and will run if you use the “Measurements/Open Seamly Me” menu selection.

There is no apparent way to execute SeamlyMe without going through the Seamly2D program, so this is different than how the program operated in previous (installed from ppa) versions.

2 Likes