Yakkety vs Zesty Ubuntu version


#1

I have been using the standard updater to get your development builds on Ubuntu. Recently I updated to version 17.04 and I no longer get updates. I used

sudo add-apt-repository ppa:dismine/valentina-dev

to add the repository, but the pointer still points to the ubuntu 2016 version (yakkety) instead of the 2017 version (zesty). Do you plan to start adding a copy of your latest build to the zesty ubuntu repository?

FWIW, many of the quirky behavior I saw in valentina in ubuntu yakkety version is now fixed when I run the same valentina under ubuntu after the zesty version. I am sure that is because I picked up a later version of Qt with their update.


#2

I don’t know what are you talking about.

Check your settings as i remember with PPA channel Ubuntu also saves distribute version. After the update your must update it manually to newer version.


#3

I did the update and it did update the distribute version. This has been working for months, since February when I added the ppa, That is the issue. In April, the distribute version was yakkety. In May, the distribute version is zesty. The reason I ask is that I noticed that there was nothing for valentina when i did the update last two mondays, May 1 and May 8.

I attached a file showing the errors. I aplogize for it being long, I took out some irrelevant lines and inserted the note … snipped to show where I did the edit. Please see the yellow highlighted area.

My question is that I don’t know whether this will fix itself automatically. It will affect any UBUNTU user who loads the distribution update from the ubuntu site. I am just the first to report it.zesty-ppa.pdf (18.1 KB)


#4

I told you last time. There is nothing wrong with our dev PPA channel.

According to your logs you don’t have valentina-dev PPA. You have only PPA for stable release. And yes, it doesn’t have version for Ubuntu 17.04.

As always absolutely wrong assumption.


#5

Actually, I have always used the ppa.launchpad.net/dismine/valentina-dev/ubuntu repository and it has worked since February. I do NOT use the ppa for stable release, and I have not since you explained the difference (I believe in Feb).

Thank you for your assistance, though. You did help me discover the problem. I had to check the box to include your repository because the updater for ubuntu disabled it by default. Also you might want to be aware of the next line (after the red arrow) on the screenshot. I do not use the ubuntu updater to look for valentina source, but someone may try.