Warnings on loading .val and using drawing tools


#1

Hello, the first time in a month I open one of my existing patterns in Seamly2d I get this warning:

WARNING Qt AtSpiAdaptor: Accessible invalid: QAccessibleInterface(0x2bc8a70 invalid) "/org/a11y/atspi/accessible/2147483775"

I can click “close” and afterwards it seems like I can continue working on the .val. When I choose the point at distance and angle-tool, and put the cursor in the length-field however, I get the error “QTextCursor::setPosition: Position ‘8’ out of range”. I cannot close this pop-up window, nor any of the two seamly2d windows that are open. The same thing happens when I try using the point along perpendicular-tool, only then the error is “QTextCursor::setPosition: Position ‘1’ out of range”

I tried multiple .val files, and even starting a new file. The same thing keeps happening, only with a new file it shows “position ‘9’ out of range” instead.

I love this program and have made so many designs and patterns with it already in the past years (starting with Valentina). Could someone please help me with this error?

Thank you!

Regards, Lea


#2

Hi @Lea_Athene Can you please send a screenshot of the version of Seamly2D you have installed and tell me which Operating System you have?

And send me a .val and .vit file so that I can test it on my system, please .