Valentina Freezing on Mac OS Sierra


#1

Hi all,

New to Valentina, and to the forum. I just downloaded the app yesterday, and I’m super excited to learn all the ins and outs of it, and to see it improve over time!

I am having a bit of a problem though. When I try to draft a curve, my computer will freeze up after I click on the first point. Generally it’ll freeze for a few minutes, then I’m able to continue drafting.

I’ve got a 2011 Macbook Pro, core i7 with 8gb ram. I run more resource heavy apps without problem, so I don’t think it’s an issue with my computer itself.

I’m on OS Sierra, version 10.12.5, and I’ve downloaded the latest Valentina release, 0.5.0.

Has anybody else on Mac had similar issues? Any help in resolving this would be greatly appreciated!


#2

To help you i need to reproduce the bug. Can you for example make a video?


#3

Typical computers. Now that I’m trying to record the screen, it’s stopped happening!

Thanks a lot for trying to help out. If it happens again, I’ll try to record it and post it here.


#4

HI! I have the same problem with Mac OS HIGh SIerra!! Does it work now for you? What did you do to fix the problem?


#5

This thread is 9 months old :slight_smile: Since that time Valentina as well as Seamly are at version 0.6. Did you try the latest build of one of them?


#6

yep! I have the same issue with Mac OS High Sierra and Seamly 2d v 0.6.0!


#7

I have just been checking to see if I could repeat this. I am using High Sierra 10.13.3 and running the published Seamly2D 0.6.0.1.

On using the simple curve tool I experienced the same hang, straight after selecting the first point.

I did a force quit and checked the other curve tools. The other curve tools worked okay. I then tried the simple curve tool again, and that worked okay. Very odd.

Having rebooted, and opened the same file (unmodified) then using the simple curve tool - it still works. I cannot get it to hang again.


#8

I have had issues with other tools or operations that included similar behavior. One example is the union tool which had a bug in June or July of 2017 (Valentina Dismine’s repository). The symptom was that if I created two shapes (the simplest example of a 2 rectangles defined by 4 points each) then created detail (with seam allowance tool) for each of them, I could make it fail every time. But only the first time.

When I duplicated the error, the file was saved and would never fail again.

I have to believe that this was because some information was saved in the file which allowed the program to work properly on subsequent runs. If you manage to duplicate the error again, I would sugest making the simplest possible set of steps to duplicate it, then examine the files in a text editor or xml editor to see if something is getting saved even though you have not intentionally saved it.


#9

I reset my machine back to its pre-HighSierra state, re-installed the macOS update and tried the curve tool. This time it didn’t freeze at all. This is odd, and rules out both that the .val file is altered in some way, or that some other piece of configuration is being saved.


#10

The latest Mac OSX build of Seamly2D fixes the High Sierra installation problem. :smiley: