Trouble Opening Seamly2d on OSX 10.9.5


#1

Hi… I’m new to seamly2d. I am very excited about it… however, when I download it (to both of my mac computers running OSX mavericks (10.9.5), it won’t open… it says there is an error… I understand seamly2D should run on OSX 10.9.5… so I’m not sure how to fix this issue so that I can run the application. Any assistance would be greatly appreciated…Thankyou…

"SEAMLY2D CANNOT BE OPENED BECAUSE OF A PROBLEM…

Check with the developer to make sure Seamly2D works with this version of OSX. You may need to reinstall the application. Be sure to install any available updates for the application and OSX.

Click report to see more detail information and to send a report to apple."

I have tried attaching my error report, but apparently it is too long to include here.


#2

Does anyone who uses Seamly on the Mac platform know how to help @ev_angeline7? @slspencer?


#3

I’ve added some more info about my issue that I hope will be helpful: The interesting thing to note is that I tried installing Seamly2d on both my mac systems (an older macbook and a more recent imac with 3.1GHz intel core i7, 16GB DDR3 RAM)… both have mavericks 10.9.5 installed. The installer will copy the software to my applications folder, but will not open: I get the error message I noted above. I have run etre check, but I can’t see anything obvious hindering the application from opening (on both systems). I do have an earlier version of valentina installed on my imac, which runs fine–curious as to whether the issue was limited to seamly2d, I downloaded the newest version of valentina to try… But I cannot install the newest version of valentina on my imac or my macbook either (and they should install according to the compatibility info for both packages). I am more interested in the direction seamly2d is headed, but I can’t seem to figure out what the problem is… any help would be greatly appreciated.


#4

Hi @ev_angeline7 , I really don’t know what to say since I’ve never worked on a Mac and nor do I know anything about programming. There are a number of people on the forum who do run on Mac and do know a lot more than I do, so I’m hoping someone will be able to help you. We just have to wait until one of them come online :frowning:

In the meantime, have you tried uninstalling and re-installing? Sometimes this will get it to work. And if that doesn’t, perhaps you could try downloading the program from the repository? You’ll find that here: https://github.com/fashionfreedom/seamly2d. Near the bottom of the page is the stable version:

image

I hope one of these 2 suggestions help you. Please keep me posted on how you get on.

Thank you :slight_smile:


#5

thanks Grace! I have tried uninstalling and reinstalling several times. I have tried the github repository and the download from the seamly page (I’ve tried both the stable and development versions)… I get the same error message… Could seamly2d need a resource that I don’t have installed (it wouldn’t by chance need X-code installed??), I uninstalled x-code some time ago to install x-quartz… I’m not into programming either… however, my error report tells me this:

Exception Type: EXC_BREAKPOINT (SIGTRAP) Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information: dyld: launch, loading dependent libraries

Dyld Error Message: Symbol not found: __os_log_default Referenced from: /Applications/Seamly2D.app/Contents/MacOS/…/Frameworks/ QtCore.framework/Versions/5/QtCore Expected in: /usr/lib/libSystem.B.dylib in /Applications/Seamly2D.app/Contents/MacOS/…/Frameworks/QtCore.framework/Versions/5/ QtCore

I’m not sure that tells what is wrong… but maybe someone can make some sense out of it or tell me what else I can include to help resolve the problem.

I do appreciate you responding, thank you kindly :slight_smile:


#6

I just tried installing version 0.6, and got this error (well this is part of the error log):

Process: Seamly2D [8943] Path: /Applications/Seamly2D.app/Contents/MacOS/Seamly2D Identifier: org.seamly2dproject.Seamly2D Version: 0.6.0 (0.6.0.0) Code Type: X86-64 (Native) Parent Process: launchd [250] Responsible: Seamly2D [8943] User ID: 501

Date/Time: 2018-12-10 22:39:00.980 -0500 OS Version: Mac OS X 10.9.5 (13F1911) Report Version: 11 Anonymous UUID: FB0BD48E-5491-31DB-1473-CF78C0347E55

Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_CRASH (SIGABRT) Exception Codes: 0x0000000000000000, 0x0000000000000000

Application Specific Information: abort() called

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread 0 libsystem_kernel.dylib 0x00007fff8cf20866 __pthread_kill + 10 1 libsystem_pthread.dylib 0x00007fff92fd635c pthread_kill + 92 2 libsystem_c.dylib 0x00007fff8832bb26 abort + 125 3 org.qt-project.QtCore 0x000000010ac56d0d qt_apple_check_os_version() + 317 4 org.qt-project.QtCore 0x000000010ab9a3b9 QCoreApplicationPrivate::QCoreApplicationPrivate(int&, char**, unsigned int) + 153 5 org.qt-project.QtGui 0x000000010a4ad53e QGuiApplicationPrivate::QGuiApplicationPrivate(int&, char**, int) + 14 6 org.qt-project.QtWidgets 0x0000000109efe568 QApplication::QApplication(int&, char**, int) + 56 7 org.seamly2dproject.Seamly2D 0x00000001099803f8 VAbstractApplication::VAbstractApplication(int&, char**) + 24 8 org.seamly2dproject.Seamly2D 0x00000001095d7e55 VApplication::VApplication(int&, char**) + 21 9 org.seamly2dproject.Seamly2D 0x0000000109628477 main + 1415 10 libdyld.dylib 0x00007fff936795fd start + 1

Thread 1:: Dispatch queue: com.apple.libdispatch-manager 0 libsystem_kernel.dylib 0x00007fff8cf21662 kevent64 + 10 1 libdispatch.dylib 0x00007fff8b795421 _dispatch_mgr_invoke + 239 2 libdispatch.dylib 0x00007fff8b795136 _dispatch_mgr_thread + 52

Thread 0 crashed with X86 Thread State (64-bit): rax: 0x0000000000000000 rbx: 0x00007fff78af7310 rcx: 0x00007fff566aa688 rdx: 0x0000000000000000 rdi: 0x0000000000000707 rsi: 0x0000000000000006 rbp: 0x00007fff566aa6b0 rsp: 0x00007fff566aa688 r8: 0x0000000000000040 r9: 0x00007fff566aa500 r10: 0x0000000008000000 r11: 0x0000000000000206 r12: 0x00007fff566aac3c r13: 0x00007fff566aac3c r14: 0x0000000000000006 r15: 0x0000000000050a00 rip: 0x00007fff8cf20866 rfl: 0x0000000000000206 cr2: 0x0000618000022018

Logical CPU: 0 Error Code: 0x02000148 Trap Number: 133


#7

Bleh! all that these errors tell me is that seems that it’s not installing the Qt .dll files that it needs to run and it should install them.

Qt is the same type of software as x-code and x-quartz, but you don’t need to have it installed, and I don’t think that having one of those installed would make any difference, but I wouldn’t know since I really don’t know Mac.

Would it be possible to uninstall x-quartz and then try to install Seamly2D and check if will work?

If it does work, then try to install x-quartz again and see if that will make a difference to Seamly2D.


#8

I installed x-quartz to use other software… can’t remember if it was Inkscape or not… but I don’t use inkscape that often anyway. It’s definitely worth a try… I appreciate your input., thank you Grace. :slight_smile:


#9

No, uninstalling xquartz didn’t help at all. I deleted all references/files associated with xquartz, shut down, restarted and then tried reinstalling seamly2d fresh, and the newest valentina as well. …I got the same error message. It would seem I’m missing a file, or a reference and that is halting me opening the program??.. and I don’t know what it is, and why it’s not there. I searched my drive and I don’t seem to have a file by this name… Am I missing a correct “path” somewhere? I have had no problems installing other software, so I’m puzzled.

Exception Type: EXC_BREAKPOINT (SIGTRAP) Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information: dyld: launch, loading dependent libraries

Exception Type: EXC_BREAKPOINT (SIGTRAP) Exception Codes: 0x0000000000000002, 0x0000000000000000

Application Specific Information: dyld: launch, loading dependent libraries

Dyld Error Message: Symbol not found: __os_log_default ** Referenced from: /Applications/Seamly2D.app/Contents/MacOS/…/Frameworks/QtCore.framework/Versions/5/QtCore Expected in: /usr/lib/libSystem.B.dylib in /Applications/Seamly2D.app/Contents/MacOS/…/Frameworks/QtCore.framework/Versions/5/QtCore


#10

Yes, for some reason, it’s not installing the QtCore file. This is what mine looks like: image

Can you follow the path and see if the QtCore file is really missing?


#11

Since I am on mac osx, the seamly application houses the Qt files does it not? I thought they were supposed to be in the application “contents”. Or should QT files be somewhere else on my drive (in application support)?

There is no __os_log_default file on my drive… I’m not sure what symbol means, I’m not sure if that __os_log_default is a path reference or not…QTCore is in the seamly2d.app contents, but as to whether it was supposed to install support files elsewhere on my drive, I am not sure.


#12

You should have a folder called “Seamly2D” in your Applications folder. And there should be a whole lot of files and folders inside it. Somewhere in there should be a QtCore file.


#13

Yes, there is… everything there looks in tact. The Qt files are in there…


#14

I’ll think about it a bit further. Thanks for checking :slight_smile:


#15

Thank YOU Grace! I appreciate your responses… hopefully something will come to light or someone in the know will see this thread and respond. I am really hoping to be able to use this software. Have a great night!


#16

@MrDoo, can you perhaps help here? What version of Mac are you operating on? Please?


#17

I have an idea that we are going to have to ask the programmers to check this out. In the meantime, would it be possible to use this earlier version of Valentina until we can release a version of Seamly2D that will work on your OS or have a solution for you?

Any patterns that you create will be able to be opened in newer versions, so you won’t lose any patterns or measurement files. And you will, at least, be able to learn the program and get some usable patterns made.


#18

Yes, that sounds fine. It’s good to know I will be able to open anything made in an older version of valentina in a new version of seamly2d. I know my issue is not the only one. I did see atleast one other post about the same issue from June (https://forum.seamly.net/t/required-configuration/2685). Thank you for your attention to this matter. I look forward to using the software when it is fixed. :slight_smile: