Problems with installing seamly2d / Ubuntu

Hi there, I am new to this forum and also not used to communicate in a forum at all, so please excuse if I make some mistakes in the beginning… (is this the right place to post my question at all…?!) When I found seamly2d a few days ago, I was so excited as I was thinking about getting a patternmaking program for a long time now, but just couldn’t afford it (I learned to use GRAFIS way back in university). Unfortunately, I couldn’t start yet as I even didn’t make to install seamly2d :frowning: This is what happens when I follow the suggested steps to download and install seamly2d for ubuntu: Bildschirmfoto%20vom%202019-08-05%2022-35-45
I use the 16.04.1 LTS version of ubuntu. Can anyone help me with this issue? Thanks in advance :slight_smile:

1 Like

@anne did you remember to do all three steps?
@anne hast du daran gedacht, alle drei schritte zu machen?

sudo add-apt-repository ppa:susan-spencer/seamly2d

sudo apt-get update

sudo apt-get install seamly2d

1 Like

Yes, I have done the first an second step before, the ppa has been downloaded properly as far as I can see, just the installation didn’t work. I will talk to the husband of a friend of mine, who happens to be an IT expert, maybe he can help me…if not, I will get back to you! Thank you anyway for the prompt reply :slight_smile:

@anne, Verzeihen Sie mir bitte, wenn ich Sprachfehler mache. Ich verwende Computerübersetzung.

Aufgrund der Tatsache, dass Sie einen Screenshot zeigen, war ich nicht in der Lage, Ausschneiden und Einfügen durchzuführen. Daher musste ich vom Deutschen ins Englische übersetzen, indem ich nur Teile von dem eintippte, was ich auf Ihrem Screenshot sehe.

Es sagte etwas über unerfüllte Abhängigkeiten aus. Es würde mir helfen, Ihnen zu helfen, wenn Sie mir helfen können, den gesamten Screenshot ins Englische zu übersetzen. Leider spreche und lese ich fast kein Deutsch

Ich glaube, Ihr Problem hängt damit zusammen, dass die richtige Version von Qt und die entsprechenden Tools installiert sein müssen, um Abhängigkeiten zu erfüllen.

Forgive me please if I make errors in language. I am using computer translation.

because of the fact that you show a screenshot I was not able to do cut and paste, so I had to translate from German to English by typing in only portions of what I see on your screenshot.

It said something about unfulfilled dependancies. it would help me to help you if you can help me to translate the entire screen shot into English. Unfortunately I speak and read almost no German

I believe your issue is related to needing the correct version of Qt and corresponding tools installed to meet dependencies.

I have to admit that I just had to look up what Qt actually means…:flushed:.Unfortunately, even if my English is good enough to understand most of what I read, I am not sure if its good enough to translate a text correctly into English, especially when it comes to technical terms. Right now, I am a bit in a hurry and also won’t have access to my computer for the next few days. As soon as I come back, I will try to translate the screenshot with the help of my friends husband, then I will get back to you. Thansk for taking the time to help me!

1 Like

Ich tippte so viel ein, dass ich das Problem übersetzen und verstehen konnte.

Sie werden es wahrscheinlich dem Ehemann Ihres Freundes zeigen wollen, bevor Sie es versuchen.

Ich glaube, dass Sie Abhängigkeiten in Ihrer Installation gebrochen haben und sie möglicherweise vor der seamly2d-Installation bestanden haben. Der Screenshot hat Sie aufgefordert, ‘sudo apt-get install’ ohne Angabe von Paketen auszuführen.

Ich glaube, du solltest es versuchen. Weitere Informationen finden Sie unter https://linux.die.net/man/8/apt-get.

Dies ist ein Teil der Beschreibung von dieser Seite:

** - f **, ** - fest gebrochen **

Reparieren. Versuchen Sie, ein System mit fehlerhaften Abhängigkeiten zu korrigieren. Wenn diese Option mit install / remove verwendet wird, können alle Pakete weggelassen werden, damit APT eine wahrscheinliche Lösung ableiten kann. Alle angegebenen ** Pakete ** müssen das Problem vollständig beheben. Diese Option ist manchmal erforderlich, wenn APT zum ersten Mal ausgeführt wird. APT selbst lässt nicht zu, dass fehlerhafte Paketabhängigkeiten auf einem System vorhanden sind. Es ist möglich, dass die Abhängigkeitsstruktur eines Systems so beschädigt ist, dass ein manueller Eingriff erforderlich ist. Die Verwendung dieser Option zusammen mit ** - m ** kann in bestimmten Situationen zu Fehlern führen.

Konfigurationselement: * APT :: Get :: Fix-Broken *.

I typed in enough so that I could translate and understand the issue.

You will probably want to show this to your friend’s husband before you try this.

I believe that you have broken dependencies in your installation and they may have existed before the seamly2d install. The screenshot was telling you to run “sudo apt-get install” without specifying packages.

I believe you should try this. Please see https://linux.die.net/man/8/apt-get for additional information.

This is a portion of the description from that page:

-f , –fix-broken

Fix. Attempt to correct a system with broken dependencies in place. This option, when used with install/remove, can omit any packages to permit APT to deduce a likely solution. Any package (s) that are specified must completely correct the problem. This option is sometimes necessary when running APT for the first time; APT itself does not allow broken package dependencies to exist on a system. It is possible that a system’s dependency structure can be so corrupt as to require manual intervention. Use of this option together with -m may produce an error in some situations.

Configuration Item: APT::Get::Fix-Broken .

1 Like