Problem generating non-tiled pdfs from Layout

Hi all,

I’m using Seamly on Windows 10. I’ve created a pattern and it’s showing in Layouts using A0

It shows up in print preview (Not Tiled PDF Preview)

However when I print to PDF, the PDF is blank. (Yes I’ve adjusted the paper size to A0 in Printer Preferences). I’ve tried this with 2 PDF creators. The page size is correct in the PDF (A0), however, it’s blank. I’ve also tried it using A1 and it’s the same.

If I export it as an SVG, I can print to PDF correctly in Inkscape, but just not from Seamly. I’ve tried it in Valentina and it has the same issue.

Any ideas?

1 Like

Did you choose “print to PDF” or “export to PDF” ?

1 Like

I’m using print to PDF.

1 Like

I was able to use print to pdf. I did this by selecting print to file in the print screen

Pude usar imprimir a pdf. Hice esto seleccionando imprimir a archivo en la pantalla de impresión


1 Like

I think it might be a Seamly -> Windows problem.

I’ve run another forum users pattern on a Linux Virtual Machine and it generates the pdf fine, but the same pattern on my windows generates a blank A0 pdf. I’ve tried using Bullzip PDF and CutePDF but both have the same problem.

1 Like

@Grace is on holiday. when she returns maybe she can look into this further. If someone wants to give me .val and .vit file I can look further into this on a linux machine.

1 Like

But this problem won’t appear on a Linux machine. It seems to be a Windows only problem.

1 Like

Why you don’t use “export to pdf” and print this?

1 Like

Hi, I’m back from holiday :slight_smile:

Unfortunately, I only have a small A4 Epson printer, so my options don’t allow to create a page larger than an A3, so I won’t even be able to try for you.

Here are a few topics that may help to solve your problem:

Please let me know how you managed or if you haven’t managed and I’ll look into it further. :slight_smile: Thank you

I loaded up Seamly on my laptop to check it wasn’t something going on with my main PC, but it did the same thing.

Again, it seems to only be a problem at A0 and A1 sizes. A2,3 and 4 all generate pdf’s with the pattern pieces.

2 other things I’ve tried.

In Windows Print Server the ISO A0 and IS0 A1 sizes that CutePDF Printer finds are slightly different from the default A0 and A1 sizes in Seamly (ISO A0 is 118.89 instead of Seamly’s 118.9, ISO A1 is 54.41 instead of 54.4). I thought this might be causing a conflict, so I created a new forms as A0 and A1 with the same sizes as Seamly uses. This still produced a blank PDF.

Next I tried setting using the “Custom (96dpi)” setting in Layouts, and either the 118.89 (ISO A0) size or the 118.9 (A0) size, with my pdf printer set to the same Paper size. Both ways still produced a blank PDF.

The print preview shows correctly image But still prints to PDF blank.

as @Dina suggested Export to PDF seems to work though and produces an A0 sized PDF, so I’ll use this if I don’t need to add other marks/features.

1 Like

Oh, wow! Thank you very much @Spitooine & @Dina, I learnt something new :slight_smile: The Export to PDF option does work very well. :star_struck::star_struck:

1 Like

sounds like something that a person who has both windows and a printer that will print A0 needs to look at. I will create an issue on github to document this, but intuitively I think it may be something about windows and a specific printer driver.

@Spitooine, what make and model of printer or plotter are you using and can you give any information about the printer driver? Also, you said this problem does not show up in Linux. Have you been able to try this? If so, can you tell me anything about your linux configuration? Thank you so much for your assistance

1 Like

@kmf I don’t have a plotter/printer. It’s when using print to PDF using a PDF creator (Bullzip, Cutepdf, pdfcreator) to make an A0 size PDF so I can take it to the nearest copy shop. I don’t have Adobe acrobat, so can’t test it using that.

It worked fine under Linux Mint 18.04 using the cups PDF creator from the package manager.

1 Like

@Spitooine, I have several, all open source but have not used those three.

One (who knows if it is related) observation is that when I attempt to print ANY pdf file using ocular to my Lexmark T640 (letter sized only) printer using the cups protocol and the driver packaged with Ubuntu 18.04 any print fails from ocular. Those same files can be printed properly using LibreOffice Draw or write.

The issue is not the same as yours. What Ocular and many other packages do is result in errors printed on the output page. I assume that LibreOffice does some command to the printer or driver to initialize something.

If you are interested in helping to track this down, I would welcome your help. I do not think the issue is in the Seamly code, but there is clearly something I do not understand. I have several computers and they include one windows 7 and one windows 10. If you have a specific .val file that demonstrates your issue please share it. If you have the same issue with every .val file I want to know that.

I use this trivial file to test the pdf creation and print function: a0test.val (2.3 KB)

I can do some research to find if there are any additional open source pdf creators that would work on windows 10 for the “print to file” function.

1 Like