Multiple boot system. deciding whether to make a separate boot environment

qt
compile

#1

I have the ability to create multiple boot environments in my system. Currently I have one KUBUNTU (KDE Plasma 16.10+ close to bleeding edge) installation where I spend most of my time. I have a windows 10 that I use for programs only available on windows. I have a second KUBUNTU 16.10 right from the distribution upgrade. I have WINE installed to emulate windows on my main KUbuntu system.

After spending some time reading code and documentation to decide how to best help make a contribution to testing, I decided I need to check out a copy (using the bitbucket valentina feature branch) and teach myself how to build the valentina program so that I will not have to ask stupid questions.

I was an expert coder but I am the first to admit that I have only lurked in open source projects and never coded there. Also the last time I wrote or compiled code it was prior to 2005. but I digress.

The reason for this post is that I got as far as needing to execute

hg pull && hg update feature

and I realized I needed to install the mercurial package. Watching this process made me stop to think whether or not I should create a “clean” bootable environment to tinker and build and keep any test suite development effort separate. @slpencer do you have an opinion?


#2

Instead of multiple boot - try virtual machine - eg Vmware player or Virtual Box. On a linux box you could try Docker


#3

Thanks for the suggestion @bamba. I actually already use a virtual environment (WINE) to run windows under linux. In addition, I already have multiple boot set up and working for those times when I can’t avoid running Windows 10. I have 3 physical hard drives and play with my partitions for fun. I have mirroring and backup and schemes so that I will not lose important data. I was once an operating systems programmer and I love to tinker.

My REAL question was that if I wanted to do any serious testing of Valentina down the road, should I keep a “clean” environment and not have any potential contamination from a system that I set up where I can build from source code.

so far, I have not come up with a reason this would be an issue but I am not done considering yet. Many brains are more likely than my one brain to think of a potential problem before I stumble on it by accident


#4

Let me clarify one reason that the question of a “clean” system environment might be important. I am using the same computer “box” to do three entirely different tasks.

  1. tinkering, hacking, educating myself
  2. creating patterns 2a) patterns for making costumes at my theater 2b) patterns for making clothes for me or others 2c) patterns to post to a repository to be used as examples
  3. testing 3a) documenting issues encountered in running Valentina 3b) creating comprehensive test suite for use at some future time

In the testing activity above it is really important that I am conscious of the precise version of Valentina software that I use and also versions of system libraries and other supporting tools.

I have answered my original question, which is YES I do need to create a separate bootable environment to do any development of a test suite of tools or procedures.


#5

The virtualisation systems allow for ‘snapshotting’ to freeze a specifice configuration. Uner linux - you could use a BTRFS file system for your Valentina workspace.


#6

Thank you @bamba obviously I need to look into BTRFS file system. I am still having a problem with getting the exact configuration set up for QT at the moment. The initial UBUNTU install did not include samba and I installed that, but am still having trouble with what I assume is QT related configuration in the UBUNTU environment. The symtom is when I select “save as” Valentina shows the warning "Invalid URL: QUrl(“pattern.val”). I click “OK” to dismiss the warning and I get the pop up to allow me to select a filename to save. Example I want to save as “foo.val” - I backspace to change the name and get the Invalid URL message again. I dismiss the warning and I have to do this for every keystroke as I backspace over “pattern” to type in “foo”. If I ignore all this and get the name I want and click “save” the file is saved and all is well.

The Valentina program works perfectly in this regard in the windows version (latest test build) both if I boot in windows directly or if I run the windows version under WINE.

This makes me think that it is something not set up properly with regard to QT and I am still trying to discover what that is.


#7

Looks like you are talking about issue #613. You can find bunch of similar warnings in other projects if will search like this kf5.kio.core: Invalid URL: QUrl.


#8

@bamba: OK, so I read http://www.virtualtothecore.com/en/2016-btrfs-really-next-filesystem/ since I had not yet heard of BTRFS and I have some idea what you are talking about. Yes, I see some possiblity that the file system can be useful and I have been toying with the idea of adding a large storage device where I would see BTRFS as useful. However, for now I really need to understand all of the factors that exist outside of the valentina.exe file


#9

@dismine you are correct, this is definitely the same issue. perhaps I may be of some assistance - i will certainly let you know if I figure anything out. I am intermediate in linux knowledge. I was once advanced in operating system skills but that is prehistoric. so far I have narrowed it down to something outside the valentina application itself and i am busy trying to teach myself enough about the external factors to see what is causing it.


#10

You try to use QLoggingCategory::setFilterRules and suppress the warning for category kf5.kio.core. This is one string of code.


#11

thanks. I may do that, since teaching myself how to build a local copy of the valentina program is actually on my to do list. i stumbled on valentina thinking i would just use it to build patterns, but now after talking with @slpencer I will probably get a bit more involved. meanwhile I found your issue 613 and added a note with my particular linux configuration. I saw that @fabrice initially reported the issue under Fedora. I am proud of myself for figuring out that it was QT related, since 2 days ago I had never heard of QT :innocent: Meanwhile I will ignore it when I am using valentina to create pattern blocks.


#12

and I will quit poking around looking for some configuration or environment variable to hack since I understand that the warning can be suppressed in code


#13

Please, write correct name. Not QT (Quick Time), Qt. Just want to avoid future misunderstandings.


#14

@kmf You can run several Valentina versions on your Kubuntu : a version from Valentina repo, a compiled one etc. You don’t have to do complicated things. To compile you will have to install some devel packages and use the console.

@dismine I think the error logging is actually problematic. There are painful spams and I suspect there is a nasty bug under the hood. I receive many XCB errors on the console when the error callback is disabled : QXcbConnection: XCB error: 3 (BadWindow), sequence: 59203, resource id: 23218531, major code: 40 (TranslateCoords), minor code: 0 But I don’t experiment any more Valentina freeze with an empty error window. Thus I suspect this XCB folk is catched by Valentina and freeze it when the error window is opened. Unfortunately Linux desktop have many nasty bugs and they are all reported by the Qt error system.


#15

@fabrice I know that there are many nasty bugs under the hood of the plasma desktop which is the one packaged with KUbuntu. It has enough features that work that I am willing to put up with it. One piece of evidence I have of these errors outside the scope of valentina is illustrated here in a screenshot I will upload. I have been experimenting with different versions of Ubuntu since release 13.4 and tried the Gnome, Unity, and KDE (plasma) desktops. Many people advocate using “Mint” instead. I don’t know enough yet to have a religious preference for a flavor of linux and I enjoy tinkering with them all. When I want to just use Valentina, I prefer to do it under WINE which runs a windows version. I have a religious preference against windows, especially since i allowed myself to be “upgraded” to windows 10.


#16


#17

Today I am running 0.5.0.0.a byukt in Mon Mar 6 2017 at 9:58:54 based on Qt5.6.1 (GCC 6.2.0 20161005, 64 bit) because I have added ppa.launchpad.net/valentinateam/valentina/ubuntu yakkety main repository to my list that updates whenever I do system updates. That issue is one reason I began the discussion of creating a separate “clean” environment when I decide to do testing. I understand what you were saying, @fabrice when you said

@kmf You can run several Valentina versions on your Kubuntu : a version from Valentina repo, a compiled one etc. You don’t have to do complicated things. To compile you will have to install some devel packages and use the console.

and doing “complicated things” is one of the ways I entertain myself. When I want to focus on testing valentina and be able to document issues in a useful and reproducible manner, I will remove all of the noisy variables so that I don’t flood @dismine with too much unwanted data


#18

@dismine and @fabrice I have finally stumbled on a fix for an annoying problem I have had with valentina since I started using it on KUbuntu. The problem was the persistent warning Invalid URL: QUrl. whenever I tried to save anything to a new filename.

It turns out (at least in my KUbuntu installation) that it is not a valentina problem, which I knew. It is not a Qt problem either. It was related to the installation of the SAMBA package, which will probably be slightly different in each flavor of linux desktop.

After reading on the KUbuntu forum about a different problem, I investigated and looked at https://www.samba.org/samba/docs/man/manpages-3/pam_winbind.8.html

The fix was that libpam-winbind was not installed. I installed it and used the following to verify that it was installed:

apt-cache policy libpam-winbind

libpam-winbind: Installed: 2:4.5.8+dfsg-0ubuntu0.17.04.2 Candidate: 2:4.5.8+dfsg-0ubuntu0.17.04.2

After this, I no longer see any error messages reported in Valentina about “Invalid URL: QUrl”

I am posting this because it may be useful to other linux users of Valentina and may save @dismine time in trying to respond to those questions