Measurements inaccurate after printing

The Layout image isn’t a ‘printing’ image - it’s just an image big enough to hold all the pieces. You are restricted to selecting from known paper sizes for the Layout image so that splitting it up into several smaller paper sheets for tiled printing is guaranteed to work. And if you happen to have a large-scale printer or plotter so that it doesn’t need to be split up, then you can select the corresponding paper size and print.

So for most people who print at home: First step - Generate Layout as one big image to hold all pieces. USUALLY YOU DON’T SELECT THE PAPER SIZE IN YOUR PRINTER, but will select whatever larger paper size will work. Second step - Print your one big image as a Tiled PDF to a printer. File/ Layout / Print as Tiled PDF.

That is what I ended up doing after reading some stuff on the forum. I would imagine you would have to manually edit the pdf in an editor to remove extra useless pages that show up in the tiled version?

I select roll paper 30" or 36" to create my big Layout image so that the least number of blank pages is generated in tiled printing.

Not a good idea to save Valentina patterns for edit and printing in other programs. You get into 90ppi vs 96ppi issues, and other issues which can change the pattern sizes, sometimes the Layout size changes only vertically or horizontally if the program scales the Layout image to fit certain pre-defined dimensions during file import.

Oh I wasn’t importing or exporting anything when I got that message if that is what you are referring to, just hitting save after adding another pattern piece. The message is confusing as neither of the versions number match the version I actually have…

(unrelated to this post but If someone wants to take note, or let me know if you want an actual separate post made… millimeter is misspelled at least in the layout settings.)

It’s not completely true that layout has nothing to do with printing, otherwise why would you need to choose paper sizes as that only comes into play at the printing stage. What I did just do though was just choose custom and put in the dimensions of the garment and go from there. My 9 page skirt is now 6 pages tiled as it should be :smiley: I tested it on another garment ballparking the max width of widest pieces and max height of the tallest piece. same thing. This one is down to 6 tiled pages vs the 12-16 I got on the other paper types. So that’s a win.

I will reprint with these new layout parameters when I get back to the printer and go from there.

Were you able to print out the skirt and measure to see what results you got?

oh I see your message now. No, the file format version update is not indicating a problem. It’s because we have expanded the file format to support the new features. As you noted, it’s not the Valentina program version but the *.val file format version.

You choosing a custom size for the initial Layout image works just as well as choosing roll paper to reduce blank pages in a tiled PDF. Most people wouldn’t want to go there, but you did. You are brave and curious, and this is good.

I haven’t downloaded and printed your pattern yet.

Yep there’s a problem. The draft formula is 18inches to hem. But the Layout, exported as an SVG file, shows 17.43inches. I opened the SVG in Inkscape, created a center line to measure, selected that line and applied the Visualize Path/Measure Path extension to it.

what I have been doing is measuring from the tip of the top edge down to the bottom. the 18 inches measurement is from the 2 top points without taking the downward curve into consideration.

That’s interesting file you have. Valentina can’t find correct format version for this file. See, it shows version v0.0.0. Can you send me an example (public or privately)?

Update. Found how to repeat. This is case about unsaved file.:slight_smile: Update. Patch has been released.

1 Like

I don’t see any problem here.

Here is my test file: A0test.val (2.2 KB)

This is rect 800x1100 mm. A0 format of paper sheet.

And here is result in Inkscape. I have been using version 0.92 and the latest Valentina in branch 0.6.0.

Result in pixels:

Little bit of math. 800 mm / 25.4 * 96 (dpi) = 3023,622047244 px. Inkscape result 3024.99 px.

1100 mm / 25.4 * 96 (dpi) = 4157,480314961 px. Inkscape result 4157.99 px.

As you can see difference is 2 pixels for width and less than pixel for height.

I believe you get wrong result because the tip of curve is not the best choice measure to.

Also i exported the file to pdf and opened in Inkscape. Here is result in this case:

This is actually good news because we use the same code for exporting in all cases. Scaling is correct. Looks more and more that you don’t left enough space for printer to print your layout. Or our printing settings are somewhere wrong.

1 Like

I don’t understand what you mean.? The reason i measure from the point is because my original top line was straight across and not curved. I made a point in the center of that line and made another line straight down that I manually typed in 18 inches for the length rather than using a stored measurement. I then added a second curved line connecting to the 2 points. So if i draw on my printout a straight line from tip to tip it should measure 18 inches from that line to the bottom line.

Digitally all of the measurements are correct. It is just the printout. It appears as though width wise the pages overlap a bit when taping them together but lengthwise not so much. is this correct? I tried matching up the pages with the dotted lines and that is where it was only a small bit off. If I didn’t overlap and just placed the sheets beside each other they ended up off the other way… Lengthwise even if I put the pages exactly with no overlap there was 1/2 an inch missing. What is the correct way to lay the down in order to tape them together? That way I have the best starting point to be able to tell what’s what.

What do you mean by this “Looks more and more that you don’t left enough space for printer to print your layout.”?

Reconstruct the Layout image row by row. Start at row 1, column 1 [page (1,1)] in the upper left corner of the Layout image. Complete row 1 (1,1) to (1,n) Then start the next row (2,1),= to (2,n) etc.

I know in which order to place them. I mean should the edges of each pages touch each other exactly without any overlap? Width wise it seemed to have cut lines on it that I would assume should be lined up together and then taped, but the length had no such lines.

Just follow the instructions for tiled PDF’s. By definition the paper overlaps, so you are asking about adding additional overlap. Just match up the lines around the edges of the paper, making sure in addition to match up the lines of the sewing pattern. If there’s no line incongruities then you’ve done a good job. The vertical lines and the horizontal lines around the paper edges should line up. If there’s extra overlap between the pages then the lines don’t match up. I assume that you matched the lines up where they should match without adding extra overlap. I’m sure you did a perfect job.

i did for the horizontal but there weren’t any for the vertical which is what confused me in the first place. (the little dotted lines with the pic of the scissors)

So to be very specific here: You are saying there are no vertical lines (which affect horizontal taping) along the side edges of the tiled PDF pages. Or are you saying there are no horizontal lines (which affect vertical taping) along the top & bottom edges of the tiled PDF pages?

horizontal (top n bottom) However… I just checked the pdf and I do see them there but are very close to the edge. Unless I am losing my mind they were not there on the printed sheets. If that is the case it would appear that it isn’t printing the entire length of the thing… Maybe…I’m tired and could be making stuff up at this point lol (printouts are in another town from me atm and my memory sucks) “IF” that is the case, it could account for the difference in measurements. I will have to double check… But to be clear, there SHOULD be these dotted lines both horizontal and vertical to aid in matching them up?

Yes these lines should be there. Maybe the top & bottom margins on your printer don’t match the top & bottom printer margins in the Layout dialog.

I will look into it and post my results

1 Like

As i said before, you probably did not set properly printer margins. In other words each printer has none printable area you should keep in mind. Valentina tries set for you minimal values, but that’s not always a correct way.

And again, printer margins you should set before you create a layout.

So…I don’t see any settings for margins in any of the printers settings/properties on the PC. (unless there are some you have to manually set on the printer itself.

Isn’t the margins what this setting is all about? Was I incorrect in having it checked? Should I have it unchecked and leave everything at 0?