Issues with Notches

A couple things that might need fixing in the Notches department.

I can’t figure out how to have notches on the mainline, (such as if the seam allowance is included in the draft,) without also having seam allowance on. It can be worked around by the setting seam allowance to 0, but I thought it was supposed to show even without turning seam allowance on if it was set to use the mainline. Maybe if an “off” seam allowance would actually be a 0 instead of null?

The other problem turned out to involve features beyond the scope of this thread.

That’s all for now.

1 Like

You still have to set the “Show second notch on seam line” in the pattern preferences. This one caught me a couple times too as I was working on the notches.


As it is right now the pref setting has to be set as well as the checkbox in the dialog…not my doing. I’m thinking the behavior should probably be changed so that the dialog overrides what ever the the pref is set at. It’s suppose to be a pref to set the dialog to a default, it shouldn’t be required to have both set. I will add it to things to improve on the notches.

Here’s a example of placing a notches on the seam line as well as displaying a notch (A12) with zero seam allowance. Note that setting the show notch on seam allowance has no effect if the there is 0 seam allowance.


One thing I am aware of is that if the seam allowance is say 0.1 then the notch will display at what ever the length is set at… such as:


I’ve debated whether or not to limit the notch length the the seam allowance width?

I’m also aware that there are some other anomalies in the rendering of certain notch types… specifically when on curves.


If we were one of those boards with silly titles, I would dub you “Hero of the Seamly notch!” Which probably explains why we don’t have those.

Maybe have that as one of the Preferences? Defaulting to not, I think. I can’t imagine why someone would want a seam allowance that small, but if they did I think they might like to be able to have the notches remain at a default size, even though it overlaps the seamline.


1 Like

Yes… a checkbox preference to limit the notch length to the seam allowance makes sense. :slight_smile:


i’m using QT VERSION 5.13.2.

i’m unable to get the notch at A49 to be straight, or visible. I’ve tried various options though


Hmmm… yeah I replied in the other topic, but I noticed the A49 notch is also not showing on the SA.

Can you post the pattern and any measurement file so I can take a closer look?

1 Like


I think that A49 was added later and is out of order and this is why the notch isn’t showing in the correct place. Make sure that that section goes A14 > curve > A49 > curve > A48, and see if this doesn’t fix your problem.


That would be my thought too. I seem to recall you had the same sort of issue back when. I’m on my phone, so I didn’t notice that the notch is there, just not in the correct place. I also forget what the fix was?

Usually when something is not working in a piece, it’s path related… or indirectly path related such as control points issues. Unfortunately I don’t know if we can get to a point where path creation becomes totally invisible to users… especially where bezier curves are involved.


Ah! Thanks, @Douglas, that makes me think of another possiblity… It could be that the curve handle is pointing in the wrong direction but with a 0 length, so that it doesn’t affect the curve, but is placing the notch in a strange place.

yes this was it. how silly of me! i thought I had ordered them in the right sequence while adding, although clearly I hadn’t . thanks a lot

1 Like

Ah! Thanks for letting me know & you’re very welcome.

1 Like