Error reopening pattern file .val


#1

I am having an issue trying to open a file I created last night. I have not changed versions since then nor have I had any troubles with others files I have created. Rebooted machine just encase, didn’t help. (windows 10)

Basic dress block.val (11.0 KB)


#2

Your file was corrupted. Basic dress block.val (11.0 KB)

Do you remember how to repeat this bug?


#3

no idea I made it, saved it with the save button (vs file/save) multiple times then closed it when i was finished by hitting the X i imagine. I created all of the points and lines and what not inside, Used the flip tool a few times during and created the work pieces.


#4

(going purely on memory, which in my case is spotty at best) I “think” I may have gotten on of those errors while saving it that said something about 2 different version… Sounding like I created it in one version, opened it in a different version and tried to save it in the newer version.

Like this one, but with different version numbers.

Also I think I clicked “do not show again” And way I can get that to start showing again for testing purposes?


#5

In this case i don’t know how to fix it.


#6

I tried to recreate the issue and no luck so far. even with getting that same error again saving it.


#7

hi please upload jennifer mallet.vit your measurement


#8

Jennifer Maillet.vit (4.3 KB)


#9

Basic dress block.val (11.1 KB) fixed pattern


#10

kewl Thanks How did you pull that off?


#11

Probably the same way i did long time ago. See my first reply.


#12

your first reply was

dismine

Your file was corrupted. Basic dress block.val2 (11.0 KB)

Do you remember how to repeat this bug?

and the second one was :wink:

dismine

In this case i don’t know how to fix it.


#13

In my first reply i posted fixed file and asked you how to repeat the bug.

But because you cannot tell me how to repeat i cannot help you to fix the bug in the code, only the file.:wink:


#14

oh , i did’t realize you posted the fixed file. lol Was it something I did to break it / something I can avoid in the future?


#15

I don’t know what caused the error.


#16

u r welcome just by some knowledge on xml and programming.

dear @dismine may be the feature preferences::configuration::Decimal separator parts with os options damasges some decimal digits replacing DOT with COMMA corrupts decimals


#17

Are you speaking about this case, right?


#18

yes and @Trine

that i fixed her file in same way and may be some others


#19

Could you provide at least one string you fixed in the original file posted in this thread?


#20

Actually I get this message frequently, even on the first manual save after creating a new file in v0.6.0. Haven’t slowed down long enough to confirm exactly under what circumstances this occurs. It seems like it’s not a problem for me. My files are not corrupted, I have no issues with data loss.

I just click ‘Yes’ and keep going. No problem, I think it’s just an internal format version recognition issue. It doesn’t mean there’s anything wrong with your pattern.