Error reopening file after crash

Hi Everyone,

I spent forever drafting a pattern, tried to change the name of one point that had been rotated, and Seamly2D crashed, when I tried to re-open my file it had autosaved and displays an error message

“error whilst calculation formula. You can try to undo last operation or fix broken formula”

I’ve tried to “fix the formula” by entering random other information but it doesn’t work and doesn’t allow me to open the file. I can’t undo the last operation because I can’t open the file (and presumably the undo function will be blank).

Is there anything else that I can try? I saw one post in the bug section where someone managed to look at the code of the file and delete a few lines but I have no idea how to do this.

Many thanks for reading this far!



Hi Priscilla,

Yeah… changing a point name that has dependents can result in a crashing pattern. It’s really important not to change a name where a point was used in formulas elsewhere. It’s analogous to pulling the carpet out from under a tool created later in the timeline. I think we’ve all been through this while learning the app. What I found useful sometimes is to outline point names ahead of time to avoid having to change them later.

If you post the pattern and measurement files someone here should able to resurrect the file… at least a good part of it. Also if you can identify which point was changed… that is what was it orginally named and what you changed it to may help.


Thank you Douglas! I will definitely remember this for next time. It was very unfortunate that it autosaved at the critical moment…! A fantastic piece of software I’m really enjoying learning how to use it otherwise.

I’ve just figured out how to open the file in x-code on my mac and deleted the section where I was making the rotations to that pattern piece, leaving the bit of writing at the end, and it’s now opening and seems to be ok which is a minor miracle as I’ve never tried anything like that before. Beginners luck, I’ll avoid renaming my pieces from now on!


If you feel the need to rename a point… you can always make a backup with SaveAs just in case before changing the name.

BTW, your post gave me some thought and I picked up an old topic on the forums regarding auto backups. It’s a common practice in other types of software - such as the audio DAW I use - to automatically create versioned (ie differently named) multiple backups. I think I could redo some of the code to do the same sort of thing with Seamly2D, where instead of having to hack the pattern file, a user can simply try loading one of the backups until they find one that loads without error. It would also allow one to go back in history without having to delete a bunch of stuff - or performing a bunch of undo’s.


That sounds like a fantastic idea, I tried going back into my mac’s “timemachine” but that wasn’t working either, this would have solved the problem.