Can't type in measurements due to digit count limitation

measurements
localization

#1

My first time trying out this software, seems very promising but already ran into a very elementary problem that, if unsolved, pretty much would render Valentina unusable for me. I’m on a Mac, trying to create an individual with custom measurements, using the metric unit system. The problem gets replicated with centimeters and millimeters, so switching between them doesn’t help.

If I try to type in any measurement number that exceeds 100 cm, the calculated value field says “Error (mm). Parser error: Unexpected token “1010” found at position 0”. 1010 refers to whichever number I tried to type in, in this case, 1010 millimeters. If I type it in anyway regardless of that message, in the table of all measurements, it shows up as 101 millimeters when it should be 1010. If I change the units to centimeters, it will interpret it as 10,1 cm instead of 101 cm. So it seems that Tape could only accept three-digit values. All of the full height or almost full height measurements on adults will exceed 100 cm, and you’ll also hit that threshold with more common things such as the chest circumference of a tall, medium-built man!


#2

Hi,

Unfortunately i can’t repeat this bug. Tested on both last stable and develop versions.

Please, tell me which version do you use?

Also i want to see a screenshot File->Preferences window.


#3

I downloaded Valentina from the website, assuming that what I get is the newest version. Says it’s 0.4.5.3.

In the preferences, apparently the default height keeps reverting back to 92 even though I click apply or ok. Tried to take screenshots but apparently new users can only post one image per message. Let me know if this is not the preferences window that you meant… It’s a bit unpractical when Tape and Valentina both have a different preferences window which contain partially the same stuff but not completely.


#4

I see you use India english is this mistake?


#5

Also i need to know your locale. Run a terminal and run command locale. Post the output here.


#6

I’d use UK English but there’s no such thing. Frankly I don’t know what the significant difference between the different English languages is on a digital platform – English isn’t my first language, the differences are obvious when listening to spoken language but I really can’t point out massive differences in the written English that would cause understanding issues. The language was automatically set to Czech when I opened up the preferences window, even though the UI always did open up in English mode, whichever English it was. So just in case, I just picked any which one of the Englishes, if that’s even a word.

I have no idea what that locale is but here’s the output: LANG= LC_COLLATE=“C” LC_CTYPE=“UTF-8” LC_MESSAGES=“C” LC_MONETARY=“C” LC_NUMERIC=“C” LC_TIME=“C” LC_ALL=


#7

The more you give me information the more mysterious became this bug.

Usually such bugs related to thousand separator based on your locale. We did not test all possible locales thus new combinations can bring new bugs.

This mean your locale is not what command locale return.

To confirm the bug i first need to be able to repeat it. And my experience says me a locale is a source of problems.

You are new to this project, so don’t make so rush assumptions.

You see english strings because the app translated only on 48%.

And the last. The Mac port is second class citizen for now. If you will have enough patience to help me fix the bug i will fix it. If not - i will ignore it. Because all i have is VirtualBox with Mac. And debugging in VirtualBox is not how i would like spend my free time.


#8

Hi @Riku!

Welcome to the Valentina forum!

Are you in Czech Republic? If not, where are you located? Your system is telling Valentina to use Czech language and Czech math formatting. (Discussion about number formats and locale here: Decimal Point vs Decimal Comma vs Other Decimal Separators – Brilliant Maps)

Would you download the latest Valentina test version from the website? This issue is most likely related to untested localization issues, but sometimes it helps to upgrade to a newer version and see if the problem reoccurs.

Because of the difficulty in troubleshooting in VirtualBox, your speedy feedback is especially important.
VirtualBox takes much more time and effort, so we don’t have the luxury of blindly investigating issues. Thanks for your understanding :smiley:

-susan


#9

Okay @dismine just tell me what I can do to help troubleshoot this. I don’t think there’s a lot of alternative software available so I’d gladly like to solve this and become a Valentina user.

For Czech, I’m pretty sure that on startup and starting to work with the measurement file, at no point did I see any other languages in the UI than English. It was all English. When I separately went to the preferences, manually chose Czech as UI language and hit OK, the whole UI changed to Czech. When I chose English again, all went back to English just as it was on startup. It felt more like Czech was chosen by default in the list not because it would’ve actually been activated, but because it was alphabetically the first one in the list. That’s how it felt.

In my Mac’s settings, my region is different than my language. For input languages, I regularly switch between three different ones, meaning that the keyboard layout changes. But I’m still not sure how languages are related to this – regardless of language or region, lengths longer than 100 cm and numbers larger than 999 do exist. Where does Valentina pull the information from, and what does it actually need my location for, after I’ve specified a UI language in the preferences?

@slpencer Thank you. No, I have never been to Czech Republic and it’s never been set as a language, region or formatting standard on my computer. I’m in Finland, I use UK English as my system language, input languages are either Finnish, Japanese or when a USB drawing tablet refuses to work correctly with the Finnish input selected, U.S. For separator, date etc. formatting I tend to use mixes between Finnish, UK or German, if applicable. Actually earlier this year, my Mac’s calculator was having difficulties with separators: It displayed commas for decimals, but if I tried to type a comma, it wouldn’t recognize it, I’d have to type in a period instead. I don’t understand why but that issue somehow solved itself (or I unticked something, can’t even remember anymore), and now I can type in decimal commas to the calculator again. Could be related, or not. I haven’t detected any encoding or formatting related glitches on my system. Valentina is displaying commas as a separator, as it should (centimeter mode).

I’ll see what the test version does, just a moment. EDIT: Unfortunately the 4-digit error persists.


#10

Yes, it’s the combination of locale and language that determines how numbers are handled. For Canada, if in French use commas, if in English use decimals.

Maybe Valentina is confused!


#11

It would appear so… The bug is also unaffected if I change Valentina’s UI language. Nevertheless, I don’t understand why any location or language related thing would limit a unit of measurement to three digits only. Is it related to language or location?


#12

I could not reproduce this error on Ubuntu 14.04, 64 bit, locale US language US English.


#13

Valentina is probably not limiting the input to three digits, not precisely like that. Errors like these are usually side effects of a software module reaching a state which conflicts with other software modules. Usually occurs under complex conditions which test the bounds of the software.


#14

Which rule to apply for your language(s) + location(s) is unclear. So we’ll probably need to find out more about what’s happening in your system settings. This will be where @dismine knows more about what to ask you.


#15

language+location = formatting rule, similar to yellow+blue = green In your Apple menu, in System Preferences, what are the values of Language and Region?

The three digit problem may be occurring because at the fourth digit, it’s typical that a comma indicates the thousands column. It’s possible that a number formatting function may try to access the separation character to use, even though it may not use it.

If the array element or variable which contains the separation character is NULL or undefined, and the function doesn’t have good error checking procedures, then the software fails.

Library functions are from Qt or other providers, we don’t write them, and sometimes they have undocumented ‘features’. :slight_smile:

Again this is all conjecture. Which language and location (region) is your operating system using at the time you use Valentina?


#16

Mac System Preferences language & region section:


#17

Look in your Mac System Preferences > Languages & Text > Text > Spelling Is ‘Correct spelling automatically’ checked? If checked, which languages are selected in this list, and what is their order? Do you have ‘Automatic by Language’ selected? If yes, which languages & what order?

Which language is selected in Valentina - ‘English’, ‘Canadian English’, or ‘US English’?


#18

Um, such path doesn’t exist. It’s System Preferences > Languages & Region, and the screenshot above is all that there is. However if I go to System Preferences > Keyboard , there will be tabs such as Input Sources and Text. Input sources contains U.S., Finnish and Japanese in this order, and this list can not be reordered. They are the languages for changing the keyboard layout for when I type. This language setting sits in my menu bar so I can change it on the go when I need to switch basically between alphabetic and Japanese writing, and the only reason why I have U.S. there is because my USB drawing tablet sometimes worked incorrectly if the input language was other than U.S. even though the device is purchased from a vendor in Finland. It’s just bad drivers. In the text tab, correct spelling automatically is checked, and automatic by language is chosen. Valentina is now set to US English, but changing languages in Valentina didn’t affect the number bug, nor did changing the input languages of the Mac OS. If you’re concerned of the language priority orders, the only place where languages can be set to a priority order is the Lanauge & Region window whose screenshot is above.


#19

Just found out: if instead of typing in a number, I type in a formula whose result is a four-number digit, it succeeds at showing up correctly, all four digits and no errors. If I type a number with a comma, such as 1,2345678 , it doesn’t give an error.


#20

ok, Mac OSX 10.9+ is System Preferences > Keyboard > Text > Spelling Under the ‘Automatic by Language’ is a list of languages. At the bottom of the list is ‘Set up’ which allows you to reorder. So could you send a screenshot of the list, since order is important?

Could you also check: System Preferences > Language & Region > Advanced >General This is where formats for numbers, currency, and measurements are stored. Could you send a screenshot of this window also?