Bug hunting. Let's fix tool Union Details

uniontool

#1

Hello everyone, :beetle:

Recently i became getting a lot reports about file corruption after using Union tool. Could someone help me to fix this tool. I seek a reproducible way to repeat this bug. Anyone? Thanks.


Pattern showing error after using the union tool
#2

I have not yet created a pattern file that I can upload for this, but here are the steps that will reproduce it:

Really quick and dirty “pant” pattern to test union tool

  • create new pattern piece. (point A)
  • create point at distance and angle (arbitrary short length and angle) (point A1)
  • create point along perpendicular (along A1 to A; length Line_A_A1 / 5; 0 degrees) (point A2)
  • create point along perpendicular (along A to A1; length Line_A1_A2; 180 degrees) (point A3)
  • create line between points A2 A3

save file (saved file contains one rectangle)

  • create new pattern piece. (point B)
  • create point at distance and angle (arbitrary short length and angle) (point B1)
  • create point along perpendicular (along B1 to B; length Line_B_B1 / 5; 0 degrees) (point B2)
  • create point along perpendicular (along B to B1; length Line_B1_B2; 180 degrees) (point B3)
  • create line between points B2 B3

save file (this saved file contains draw mode only, 8 points defining 2 rectangles)

  • zoom best fit
  • select pattern piece 1
  • select detail submenu
  • click on seam allowance tool
  • select points A, A1, A2, A3
  • click ok -select pattern piece 2
  • click on seam allowance tool
  • select points B, B1, B2, B3
  • click ok

save file (this file contains detail mode for 2 rectangles – fake pant back, pant front)

  • click detail mode
  • zoom best fit -click on union tool -select pattern piece 1 detail -select A -select A1 -select pattern piece 2 detail -select B3 -select B2 in “do you really want to unite details” click OK

Error bad id. Program will be terminated. ExceptionBadId: , id = 11


#3

I believe this file will duplicate it. be careful to stash the original and work with a copy because the act of running this one time then letting valentina fix the file when it restarts after the error will make it work the second time. with this fileupload-union-debug.val (2.0 KB) you should be able to take the saved pattern pieces and quickly create detail, then use union tool. i believe it will fail every time - at least it fails every time for me


#4

Hi @kmf,

Thank you for your help!

Which version did you use? Because i don’t get this error. My error is different.


#5

I have opened issue #719. But looks like this not what we have been searching. @kmf, can you check changes i will make?


#6

will this be in the build on July 17?


#7

I am not positive which version I was using. Routinely I let my system update whenever there is something new available and I have it set to include the valentina test build every Monday


#8

Yes, according to my plan.


#9

I just tried the build dated July 25. I opened the file upload-union-debug.val (posted above) and used seam allowance tool (in draw mode) to create detail pieces for pattern piece 1 and pattern piece 2. went to details mode. Clicked zoom best fis. Used union tool to select detail for pattern piece 1, points A and A1, pattern piece 2 points B3 and B2.

Here is the error


#10

Already working with this bug too!:grinning:


#11

Fix has been released.

Plus i have found new bug.:slight_smile:


#12

I tried the same procedure using the file I uploaded and got the same error. This is the information about the build I used.


#13

Good. Can you please repeat for me how to produce the bug? Or even better. Can you record a video?


#14

I am sure I could record a video, but I don’t have a clue how to do it on this particular system and unfortunately I don’t have time today to figure it out. I already posted the precise steps that I used above and here is a screenshot as a reminder

To duplicate it, I use the same method each time. I have my browser open to this thread on the forum. I go to my message dated June 30 and click on the link caused when I posted the file “upload-union-debug.val”. (In this way I am sure that I start with the same file each time). Because it is a .val file, it presents me with the options “open with Valentina” or “save the file”. I open with Valentina.

From there, use the steps I documented before. It is really important to use the file that does NOT contain any detail pieces. I have found that if I allow the file to be saved by valentina even once, it apparently cleans something up and the union tool will work fine after that.

So the important thing is to have an untouched copy of the upload-union-debug.val file each time.

Hope this helps

I will be back much later in the day because I have to spend the rest of the day getting a the costumes for the entire cast of a musical ready for their opening night.


#15

Thanks, this is probably all i should to know.:slight_smile:


#16

Added issue #743.


#17

I have been away and traveling but I got home last night and updated to the build from August 7. The bug I demonstrated with upload-union-debug.val appears to be fixed


#18

Hello! I am working with the last version 0.5.999+60+3+201710161022 with ubuntu16.04.1 (Valentina-dev) after I use the union tool it’s corrupted.

Bildschirmfoto_2017-10-28_16-36-10

I created a test file, this file will duplicate it you can see it on the video. Kazam_screencast_00001.m4v (725,4 KB)

Could anyone help me? Thanks

bug_union.val (4,6 KB)


#19

Hey @trouseaux!

Currently there are people working on building the Windows, Mac, and Ubuntu versions of our software. Hopefully you will be able to download code which has a fix for this problem.

In the meantime, are you interested in building the latest code in Qt? You can get a free copy of Qt from the open source download page, and we’ll help you set it up. We need some beta testers, and with Qt you can help test code updates: https://www1.qt.io/download-open-source/


#20

Yes, I can imagine, just tell me what I can do for it and we can try it. QT is already running on the operating system. However, I am not a programmer, but convinced that valentina / libre fashion is a great program with many possibilities.